Lambda@Edge Adds Support for Node.js v8.10

Starting today, you can use Node.js v8.10 to develop your functions in Lambda@Edge, in addition to the currently supported Node.js v6.10 runtime.

Node.js v8.10, the current Long Term Support (LTS) version of Node, uses the new V8 6.0 engine, that provides better performance when compared to the previous LTS version 6.x. In addition, Node.js v8.10 supports new features such as async/await, which is a new way of handling asynchronous operations in Node.js. This enables you to write simpler, easier, and cleaner code for non-blocking calls. You can read this blog post for more details on the benefits of async/await feature introduced in Node.js v8.10.

To get started, you can simply upload your Node.js code as an AWS Lambda function through the AWS CLI or Lambda console, and select the Node.js 8.10 runtime. If you have existing Node.js functions, you can switch to the new runtime by making any required code changes to ensure compatibility with the new runtime and editing their function configuration to set the runtime to Node.js 8.10.

To learn more about Lambda@Edge, visit the product page. For more information on Lambda’s Node.js programming model, you can refer to the documentation.

 

Leave a Reply

Your email address will not be published. Required fields are marked *